Back to overview
Resolved

Download may be interrupted.

Aug 10, 2026 at 8:00pm UTC
Affected services
Website
Account Service

Resolved
Aug 10, 2026 at 8:05pm UTC

We have pushed an update to resolve this issue.

Created
Aug 10, 2026 at 8:00pm UTC

As for the new releases that have been pushed recently, the website lacks behind updating the download page to reflect the newest version.
CDN by GitHub will resume and downloads will work normally after the timeout.